eXpurgate.Cloud - Outbound delivery issue

Incident Report for eleven cyber security GmbH

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 12:13 CET

Monitoring

We identified and fixed a routing issue which was introduced yesterday at around 13:30 CET during a system update.

All emails are being delivered in the next minutes.
Posted Mar 13, 2025 - 10:05 CET

Update

We are still investigating the issue. Connection timeouts affect only a portion of outgoing emails.

All emails are queued and will be delivered as soon as the issue is resolved. Senders are receiving delay notifications. They might see errors like: Remote Server returned '554 5.4.0 < #4.0.0>'
Posted Mar 13, 2025 - 09:50 CET

Update

We are continuing to investigate this issue.
Posted Mar 13, 2025 - 09:35 CET

Investigating

We are aware of an issue affecting outbound email delivery via eXpurgate.Cloud relay.

This issue is currently under investigation.
Posted Mar 13, 2025 - 09:35 CET
This incident affected: my.eleven Cloud Email Security (Email Processing - Outbound) and eXpurgate.Cloud (Email Processing - Outbound).