eXpurgate.Cloud - Delayed Delivery
Incident Report for eleven cyber security GmbH
Resolved
This incident has been resolved.
Posted May 25, 2023 - 14:09 CEST
Monitoring
We implemented a fix, email delivery to outlook.com infrastructure is no longer delayed.
Posted May 25, 2023 - 12:23 CEST
Identified
Due to the datacenter migration and the related network infrastructure changes we are experiencing delays delivering incoming emails to Office 365 infrastructure.

The delayed emails are queueing on our systems and will be delivered as soon as the issue is resolved
Posted May 25, 2023 - 11:42 CEST
This incident affected: Cloud Email Security (Email Processing - Inbound) and my.eleven Cloud Email Security (Email Processing - Inbound).