Email Processing Delays
Incident Report for eleven cyber security GmbH
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 09:40 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2024 - 15:09 CET
Update
The delays only affect some emails of some email categories: Business E-Mail Compromise, SPF, and DKIM.
Posted Mar 15, 2024 - 14:45 CET
Investigating
We are currently observing some delays in our email processing infrastructure. Customers might see delays in delivery of Inbound emails. Sending mail clients will see the error message "Busy, try again later".

We are investigating the issue.
Posted Mar 15, 2024 - 14:31 CET
This incident affected: my.eleven Cloud Email Security (Email Processing - Inbound) and eXpurgate.Cloud (Email Processing - Inbound).