Cloud Email Security outbound delivery issue
Incident Report for eleven cyber security GmbH
Resolved
Microsoft resolved the Incident, there are no longer any delays regarding the email delivery to Microsoft servers since 11 OCT 2023 19:20 UTC +2
Posted Oct 12, 2023 - 08:17 CEST
Update
Microsoft has identified a recent service update as the cause of the issue. They are in the process of developing and validating a fix to revert to the most recent stable service version.
Posted Oct 11, 2023 - 15:43 CEST
Identified
Microsoft has opened incident # ‎EX680695‎ today at 6:22 AM UTC +2.

At the moment, Microsoft is working to identify the root cause and develop a remediation plan.

To provide immediate relief Microsoft has an allow list in place. We are trying to get the eleven IP address ranges added to that list.
Posted Oct 11, 2023 - 12:38 CEST
Investigating
We are aware of an issue affecting our outbound delivery to Microsoft Servers with an error being returned that says "Server busy, Please try again later". Microsoft is greylisting our IP addresses.

This issue is currently under investigation.
Posted Oct 11, 2023 - 11:23 CEST
This incident affected: my.eleven Cloud Email Security (Email Processing - Outbound).